YUM: Thread died in Berkeley DB library, Fatal error,

When i run Yum update in fedora,  i got this error

Error :

[root@localhost RPMS]# yum update
rpmdb: Thread/process 7977/139764163434432 failed: Thread died in Berkeley DB library
error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 –  (-30974)
error: cannot open Packages database in /var/lib/rpm

Error: rpmdb open failed


Solution :

Run this command:

[root@localhost RPMS]# rm /var/lib/rpm/__db*


rm: remove regular file `/var/lib/rpm/__db.001′? y
rm: remove regular file `/var/lib/rpm/__db.002′? y
rm: remove regular file `/var/lib/rpm/__db.003′? y
rm: remove regular file `/var/lib/rpm/__db.004′? y

Now  try  the  Update  again :


[root@localhost RPMS]# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
fedora-firefox4                                                                            | 3.0 kB     00:00     
google-talkplugin                                                                          |  951 B     00:00     
playonlinux                                                                                |  951 B     00:00     
playonlinux/primary                                                                        | 1.7 kB     00:00     
playonlinux                                                                                                   8/8
rpmfusion-free-updates                                                                     | 3.3 kB     00:00     
rpmfusion-free-updates/primary_db                                                          | 218 kB     00:00     
rpmfusion-nonfree-updates                                                                  | 3.3 kB     00:00     
rpmfusion-nonfree-updates/primary_db                                                       |  66 kB     00:00     
updates/metalink                                                                           |  27 kB     00:00     
updates                                                                                    | 4.7 kB     00:00     
updates/primary_db                                                                         | 5.2 MB     00:01     
Setting up Update Process
Resolving Dependencies
–> Running transaction check
—> Package PyQt4.x86_64 0:4.8.3-2.fc14 set to be updated
—> Package akonadi.x86_64 0:1.5.1-1.fc14 set to be updated
—> Package attica.x86_64 0:0.2.0-1.fc14 set to be updated
—> Package cronie.x86_64 0:1.4.7-1.fc14 set to be updated



  • Naveen


  • solo_programas017

    Thanks, this work…!

  • hoy1999

    thank you so much!!!!!! it works!!!!!!!!!!

  • http://www.unpocogeek.com Martin Alejandro

    Thanks, it worked perfectly ;)

  • Maneesh Kumar

    Thank You very much!!!!!

  • http://noneseek.wordpress.com/ David Mallonee

    Yep, thanks as well, worked perfectly!

  • cpadminhelp.com

    Thanks – this helped resolve my issue – though I ran “rpm –rebuilddb” after removing the corrupted db files.

  • Pingback: Fix Gcc Error Trying To Exec ‘cc1obj’ Execvp Windows XP, Vista, 7, 8 [Solved]()

  • http://www.cheapnfljerseysints.com/ wholesale jerseys

    wholesale jerseys cheap mlb jerseys paypal cheap nfl jerseys