Libreoffice 3.5 has been released!| Install in Ubuntu10.04 and 11.10, fedora, debian, LinuxMint | PPA

LibreOffice 3.5 has been released, this is a major release that comes with many new features and improvements, in this release for the first time will be enabled the online update checker which informs users when a new version of the suite is available.

What`s  new in LibreOffice3.5?

– a new built-in Grammar checker for English and several other languages
– improved typographical features, for professional looking documents
– an interactive word count window, which updates in real time
– a new header, footer and page break user interface
Impress / Draw
– an improved importer of custom shapes and Smart Art from PPT/PPTX
– a feature for embedding multimedia/colour palettes into ODF documents
– a new display switch for the presenter’s console
– new line ends for improved diagrams
– Microsoft Visio import filter
– support for up to 10,000 sheets
– a new multi-line input area
– new Calc functions conforming to the ODF OpenFormula specifications
– better performances when importing files from other office suites
– multiple selections in autofilter
– unlimited number of rules for conditional formatting
– a new integrated PostgreSQL native driver

1- Install LibreOffice 3.5 in Debian/LinuxMint/Ubuntu

If you want to install in ubuntu/LinuxMint via ppa, but you have a previous release of LibreOffice/Openoffice installed, first remove it using the command:

 sudo apt-get purge openoffice*


sudo apt-get purge libreoffice*
  • Installation via PPA (PPA updated):

Then run these commands to add the repository and to install Libreoffice in Ubuntu11.10 and LinuxMint12:

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get install libreoffice language-support-en
  • Installation using Debian Package:

To install LibreOffice in Debian/Ubuntu/ LinuxMint using debian package:

Download the debian package from this link and extract it to your home directory (In my case to /home/zinovsky/Download package 64bit)

– Now open terminal and cd the extracted directory (in my case)

cd /home/zinovsky/Downloads/LibO_3.5.0rc3_Linux_x86-64_install-deb_en-US/DEBS/

– Now cd desktop-integration and install debian menu package

sudo dpkg -i *.deb

– Back to the previous directory

cd ..

– Install Libreoffice packages

sudo dpkg -i *.deb

2- Install LibreOffice in Fedora/CentOS/RHEL:

1- First you need to download the rpm package from this page

2- Extract the package to /Download folder using the following command(Change x.x.x- to the current download release LibO_3.5.0rc3_Linux_x86_install-rpm_en-US):

tar xvzf LibO_x.x.x-_Linux_x86_install-rpm_en-US.tar.gz

3- cd the extracted directory

cd /Downloads/LibO_3.5.0rc3_Linux_x86_install-rpm_en-US

4- Now go to the RPMs directory, under root run this command to install the RPM packages:

rpm -ivh *rpm

5- Now you need to install LibreOffice menu entries. To do that cd the sub directory desktop-integration

cd /Downloads/LibO_3.5.0rc3_Linux_x86_install-rpm_en-US/RPMS/desktop-integration

6- And run the following command to install LibreOffice menu entries, there are 3 packages, install the freedesktop one :

rpm -ivh libreoffice3.5-freedesktop-menus-3.5-13.noarch.rpm

And is done

  • tracyanne

    As at 9:00Am February 15 2012 the ppa  described above

    sudo add-apt-repository ppa:libreoffice/ppainstall LO 3.4.5, not 3.5. The updates to 3.5 will probably be available in a day or 2.

  • Tuxeo

    Definitely 3.4.5. Thanks for wasting my time.

  • rubaduck

     Yup, it’s 3.4.5 and it wouldn’t let me install the English pack anyway.

  • Qubiq

    Worked well for me in Debian :) thanks!

  • Gonzrick

    I get this after trying to install:

    Package language-support-en is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, oris only available from another source

  • guest

    Its backwards, you are installing the menus before installing the core packages. If you are getting any error or unsuccessful installs, try to install the packages first then the menus in the desktop integration folder.

  • Guest

    The PPA has now been updated to 3.5 as of this morning.

  • Gonzrick

    What do you mean?  I was following the steps above for Ubuntu/Mint.  Now I don’t have Libreoffice at all but I can’t reinstall it by following the steps above.

  • David Traver

    Don’t follow the instructions regarding Ubunu, they are wrong.  You get 3.4.4, not 3.5

  • Zinovsky

    PPA for Ubuntu 10.04 and above including 11.10 is working. Just try again

  • JohnH

    Where is LibreOffice for Ubuntu 10.10?  I see 10.04 and 11.10, but no 10.10 or 11.04.  Why are those versions skipped?

  • Andrew

    Be aware there is a reported bug with using ctrl f to find text in a document:

    “type ctrl + f to search document.
    A new toolbar shows off ON BOTTOM OF MAIN WINDOW. Take off the toolbarto become a microwindow, close THAT MICROWINDOW and type ctrl + f again.
    Libreoffice crashes.”

    It works ok as long as you don’t mess with the microwindow. VERY frustrating if you don’t know what’s going on!